愚者の経験

「また今度」はほとんどこない

月別アーカイブ: 1月 2015

[SQL Server][Access]日時のフィールドで苦労した話

Accessで時刻を入力するのは若干面倒くさい。最終的に使いたい項目が日時だとしても
「日付」と「時刻」の別にフィールドを設けることが多いです。以下長文ごめんなさい。

テキストを1つにすると日付だけ既定値で入れられることが出来たとしても
時刻を続けて入力するにはキャレットを移動させるしかなく、F2キーやマウスをクリックしたり矢印キーを
使用するのを避けられないのが主な理由です。(テキスト毎にEnterイベントでSelStart入れればそんなもんですがそれもちょっと…)
他の理由としては自前のカレンダーや時刻の入力フォームが別にある場合該当のテキストへの入力が複雑になるということもあります。

さらに大きな問題としてOSの時刻の表示が「H:mm」になっているせいで定型入力が「00:00」系で例えば「09:00」
と入力しても再表示時に「9:00」となって、フォーカスすると「9_:00」となって出るときにエラーになって安定しなかったり、
時刻に24時以上を打ち込みたい場合はどうしようもないという理由で最近は時刻は文字列型にしています。
(エラーの方に関しては私が体験したもので必ずでるというわけではないです。今やってみても再現出来ない…。)

そんなこんなでフィールドを2つに割ったとして今度は利用する際に毎回「[日付]+cdate(nz([時刻],”00:00″))=……」とか
しなければいけなくなるのですが、SQLServerを利用している場合は「計算列」という機能があるので
これを使うんですがちょっと問題があります。

24時以上を入力しない場合は計算列の数式に「[日付]+cast(isnull([時刻],’00:00′) as datetime)」とやればいいんですが
「列’xxxx’の数式を検証中にエラーが発生しました。変更を取り消しますか?」と言われてしまいます。
うーんあってるはずなのに…多少書き方を変えても同じです。
どうすればいいかというと上記警告を無視して(上記ダイアログを[いいえ]で突破する)、テーブルの保存時にも似たようなことを
警告されますが再度無視し、テーブルを見ると…ちゃんと出来てますorz
この時castで書いたはずの型変換はconvert(datetime,isnull([時刻],’00:00′))に書き換わっていました。
これで書けばいいのか~とconvertで書いてもやっぱりエラー笑

「悩みまくったのは一体何だったんだ」と思いました。インデックス貼るまでは。
続いてアプリがこなれて仕様も固まってきた頃、速度改善のためにインデックスを作成しようと思って
上記の計算列を選ぶと「インデックスの作成に失敗しました」という趣旨のエラー発生。
「あ~計算列はインデックスキー列に含めないのね」と勝手に思って仕方なく付加列に追加…
出来ません!再度エラーが出ます。
なんで?と思って調べたら、以下の情報がヒット
https://msdn.microsoft.com/ja-jp/library/ms189292.aspx
「決定的」であるかどうかが重要で文字列型を日付にconvertする時は値が決定的になる第三引数が必要だそうです。
なので「convert(datetime,isnull([時刻],’00:00′),108)」とすると保存時にエラーは出ますが、インデックスは使えるようになりました。

うーん。言いたいことは分かるんですがエラー出るのは気持ち悪い。とりあえず24時対応しましたところ
(([日付]+CONVERT([int],left(isnull([時刻],’00:00′),(2)))/(24))+CONVERT([datetime],(CONVERT([varchar](2),CONVERT([int],left(isnull([時刻],’00:00′),(2)))%(24))+’:’)+right(isnull([時刻],’00:00′),(2)),(108)))
これだとエラー出ないんですよね…不思議。

[Office 2013][Access]Access2013の計算値が表示されなくなる現象

Access2013なんですが、たまにおかしい現象が出ます。
・コントロールソースに計算を入れているテキストボックスの表示が表示されなくなる
・サブフォームコントロールの親リンクフィールド、子リンクフィールドが機能せず何も表示されなくなる
主にこの2つです。
またたまに「コントロールをクリックすると表示される」という状態になることもあります。
私が知るかぎりこれはかなり厳しい状況で、すぐ思いつくことをしても大体直りません…
・最適化/修復
・デコンパイル
・PC再起動

現状戻せている方法は「システムの復元」とAccessのバージョン切り替え(Accessを複数バージョンインストールしている場合のみ)です。
おそらくAccessを再インストールしても直るでしょう…また修復で直るかは未確認ですが
クライアントのPCでしていただくにはあまりにも重すぎます…orz

試しに同じプログラムをAccess2010で動かすとちゃんと表示されるので
ファイルが壊れているとかプログラムが間違っているということではありません。
WindowsUpdateも自動で当てているPCだったのでおそらくAccess自体も最新だと思います。

当初WindowsUpdateでなにか変わったのかと思ったのですが復元先のチェックポイントまでに
「自動復元ポイント」しかなかったとしても、それで直るパターンがありました。
なのでシステムに影響があって変わったというわけでもなく、突然上記の症状になるということになります。

OSはWindows7とWindows8.1の両方で発生したことを確認しています。

この方も多分同じ症状だと思います…よく見たらこの方はAccessの修復をされたみたいですね。
http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q11125283376

あんまりこんなこと言いたくないんですが、Micr○softさんなんとかしてください、お願いします。…m(__)m

2015-1-23 追記
「[ハードウェアのグラフィック アクセラレータを無効にする] のチェックを外す」が効くかもしれません(未確認)
アンインストールする前に確認出来た方いらっしゃれば教えていただければ。
ただ、これVBAで設定する方法がわからない…VBAでレジストリいじるの入れようかな。

さらに追記
Access2010sp2でも発生…サブフォーム内のテキストボックスのコントロールソースに「=[コンボボックス名].column(1)」とか
書いてあるのも空白になっていました。もちろん合計欄見えず、親子リンク動かず。
動くPCと動かないPCが出るのでファイルサーバーのせいではなさそう。クライアントOSは全てWindows8.1 pro 64bitで
PCを再起動しても直らず、Accessを修復すると直りました。しかしサーバは開発用にAccess2013がインストールされているのですが
Access2013を修復しても現象は直りませんでした。クイック、オンライン両方でダメです。

原因が不明で再現性もなく、まったくわかりません…異常が発生したPCのプログラムとサーバのデータを持って帰り
Windows 7のAccess2013で動かしてみましたが再現せず、Windows 8.1のAccess2010で動かして見ても再現せず。
一体どうすればいいのやら。